How To Use Symbol Creator

Last Modified: 11/29/2022
Article Contents

A step-by-step guide to using Symbol Creator to add custom symbols to your database, and use them on your label design.

Instructions

The symbol creator is a powerful tool that allows the user to convert an image file into a symbol for use within LabelForge Pro. Symbols are
monochrome, scalable, and used more easily with some LabelForge features, such as adjusting the size of the symbol and changing its colors.

Accessing Symbol Creator

PC:

  1. Open LabelForge Pro.
  2. On the dashboard, click the Symbol Creator button. This is the second button from the left on the bottom row of icons.




Embedded printers:

  1. From the home screen, tap “Tools” on the right side menu. This is the fourth button from the top on the right side.
  2. Tap the Symbol Creator button. This is the second button from the bottom on the Tools menu.



Loading and Converting Your Image

  1. Once Symbol Creator is open you will be presented with the “Add Symbol” menu by default, click Load SVG / Image on the bottom right.




  2. A pop-up will open prompting you to open an image file. Select the image file you wish to convert to a symbol, and click Open, or double
    click the image.



  3. Once the image has processed, the image to be processed will appear on the left, with the symbol output on the right. In the middle, there will be a number of options for filtering your image for conversion to .svg (our base symbol file type).


    Note that multi-color SVGs can be converted to monochrome SVGs with color thresholding. A multi-color SVG conversion such as this looks like so:



  4. Adjust the filters and checkboxes until the symbol appears as you would like it to appear.
  5. Once the symbol appears as you like, you can click the Save to File button to export the symbol into a .svg file on your computer or
    embedded device.
  6. Clicking “Add To Collection” will place the symbol within our symbol database.
  7. To remove a symbol from the database, click “Remove Symbol” on the top right.
  8. On this menu, select the symbol you wish to remove, and click “Remove Selected Symbol.”



  9. You can click “Add Symbol” at the top to return to the Add Symbol menu that opens by default. 


Using Your Created Symbol in Label Designer

  1. Open Label Designer.
  2. Click the Insert menu at the top right (this menu will be open by default upon opening Label Designer and creating a new label design).



  3. Click the “Symbols” button within the Insert menu.
  4. You will be presented with a list of all symbols. User-created symbols will be added at the top of this list, but to only see User Symbols, feel free to click “User Symbols” on the left.

  5. Select the symbol you wish to use, and click Insert.

  6. You can now use the symbol as you wish! The image will rescale without pixelating, color can be added to either the outline or the background, and transformed as other symbols.

Live Chat
If we've been unable to help you with the resources available here, we're still here for you! Live Chat with a certified service representative now.
Live Chat
If we've been unable to help you with the resources available here, we're still here for you! Live Chat with a certified service representative now.